OnlineMedEd FAQ

What browser or hardware do I need for OnlineMedEd?

The site is built on a framework that takes advantage of all modern browsers, is responsive ,and will change based on the device you're using—whether that be mobile, tablet, or computer.  

The minimum requirement is using Google Chrome, Safari, Firefox, or Internet Explorer 10. If your device doesn't meet our minimum browser requirements, the site will probably still work, but it's possible you won't see all of the content in the way it's intended.

For mobile devices, our minimum requirements are iOS 11 and Android Oreo 8.0 or higher.